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Getting Started:

Taxprolink is designed to Maximize Your Bottom Line by offering an efficient, affordable,
and reliable professional tax software for any type of tax office. We offer comprehensive,
user-friendly tax software for CPAs and Tax Professionals that is sure to increase
revenue and efficiency to help grow your tax business!

Who We Are

Taxprolink, Inc. provides federal and state preparation and electronic filing for professional tax
preparers, serving thousands of customers throughout the United States. Responsible for filing
more than one million returns to date, Taxprolink, Inc. offers comprehensive tax services to meet
the needs and demands of today’s tax preparer.

Taxprolink, Inc. is based in Redford, MI

Using the Auto-Update Feature

The Taxprolink Live Updater is a feature that will automatically install any updates that
are available to your Taxprolink web-based tax Software. Updates to the program are
common throughout the tax season and are essential to ensure that TAXPROLINK
always has the latest forms and instructions from the IRS.
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Chapter One: Setting Up User Account

Click Sign in
www.taxprolink.com

Manage Your Filings from the Cloud

Let Your Team File from Anywhere

No more downloads, installations, updates, or servers. Access all tax tools from your
browser.
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Forgot Password option:

Reset password link will send to your registered email address.

Note: Create a unique password within the standard. Taxprolink detects previous passwords and make sure
totally different from the last 5 passwords you had before.
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Creating Admin Preparer

From the <Setup Tab> select <Active Preparer>. Edit < Admin Preparer>

Enter:
Preparer Information
Contact Information
PTIN #
Preparer PIN signatures information

Adding a New Preparer/ Editing Preparer Privileges

Click <Add New Preparer> and input the Preparer Information.

Create the preparer login information and set allowed privileges.
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Enter the preparer information and determine their delete/modify privileges.

NOTE: Each registered tax preparer must have a valid PTIN to be entered as a preparer.
Data entry PTIN is not needed

User Option

Then click <Create New User>.

Note: Login page: www.taxprolink.com click Sign in

Enter the Account name and password you created and same Firm Name you use when logging into your
account.
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Updating Firm Information

We will prompt you now to input your Firm’s Information.

Update the Firm’s Information and click <Save Changes> when completed.

NOTE: Check the box if you are self-employed; this will eliminate the need for a Firm EIN.

EFIN Status Summary:
You need to validate your efin # by uploading the Application Summary Page in pdf file into your Taxprolink account.

please log in to your e-services account. Click Here https://la.www4.irs.gov/esrv/esam/pages/landingPage.xhtml

Click <Print> to print as a PDF
<Save as PDF> Save to Desktop

Copy the Tracking Number and
paste it to Efin Validation Page
and attach the save Application
Summary from your desktop.
Click <Upload and Save>

Important: In order to comply with IRS efforts to prevent fraud and identity theft you must provide a copy of
your IRS e-file Application Summary from IRS e-Services, with a status of "Completed," to Taxprolnik Software
for verification.

You may submit your document to Taxprolink by one of the following methods:
Fax to Compliance at (855) 299-3299
Attach to the email and send to support@taxprolink.com
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Updating Pricing Information

From the <Individual tab> select <Pricing>

This pricing setup will determine the fee’s that you charge to your taxpayers. This setup is not required to start a
tax return but must be setup in order to file a client tax return. We recommend this information be setup now.
Select which pricing you will set first, then click <Save and Continue>.

Determine your price setting and click <Save Federal Pricing>. Click <Continue to: State Pricing

Set pricing as a Fixed Rate for all returns, to Manually Set pricing within each return, or to set a Price as Per
Form. The pricing can be edited at any time from this pricing tab.

Follow these steps for setting Federal Pricing, State Pricing, and any Discounts or Additional Charges for
your pricing structure.
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Importing Prior Year Clients

To import your prior year clients, navigate to Tools > Import 2019 Client Data. Choose Simple or
Comprehensive import clients you wish to pull forward.

Select the clients you wish to Import and click <Import Selected Returns> or click <Simple Import /
Comprehensive import > to import single returns
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Setting up the Individual Return Entry Mode

From the <Setup> Tab, Click <Settings> <Preparer Level Settings

The software, by default its preparer to the chosen entry mode when creating new return for

Individual. Click<Save Changes>

NOTE: Do this to every sub-preparers
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Chapter Two: Preparing a Tax Return

Creating a New Return

To create a new return, click the <Clients> Tab and select <New Return>.

Input the Primary Taxpayer SSN (Double entry required).

Click <Save and Continue>

You will also select the return “Type” to be completed.

The next input page will prompt the Primary Taxpayer’s Personal and Address Information.
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Interview Mode: Understanding Layout and Input Options

The online interview provides navigation tabs that run across the top of the tax return.

1 - Navigation Tabs: Once all Primary Information is entered, these tabs and sub-tabs can be used to

navigate the software to specific pages.

2 - Additional Information: Each page provides guided links, examples, and glossary items to assist you in

determining information within that page.

3 - Saving your Entries: To ensure the client information is saved, you must click <Save & Continue

Return> on each input page.

4 View / Print: To view or Print Tax forms

5 Form Search: To search tax forms and add

4 5 2

1 3

Using Navigation Tabs

When navigating the software, to access a certain form by using your navigation tabs, mouse-over the primary
tab and sub-tabs to make the form selection.

Example: To navigate to the W-2 entry page using the navigation tabs, Click the <INCOME> Tab, Click <SHOW
MORE> Click <START> to add Wages, Salaries, Tips, and select W-2 from the sub-menu. The software will
bring you directly to the W-2 page.

Simply choose to <Start> next to the needed item to input information for that form.
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When done with all forms for this section, click <Done with Section>.

F0rms 1096A 1099C. 109SCł W2-G 2S5õ, 1042-5



Starting a State Return – Interview Mode

Using the Interview Input

To navigate the Interview Input of an Individual 1040 return, simply complete the requested information

screen and click <Save & Continue Return>. Taxprolink Interview Input will guide you through the

Federal Return before prompting you to create any State Return.

To start a New State Return, either navigate through the Federal input pages or click on the <State> Tab.

The software will pull any state that is affected by income or resident entries.

To start the listed state, click <Start> next to that state.

To file another state return not listed on this page, click <Start a New State Return>.

Filing a state return is not required. If no state will be filed, click <Save & Continue Return> and <Agree> to

not file the state.

NOTE: Navigation/Input options for State are the same the Federal return.

Adding Additional States

Once a state return is completed, the software will navigate back to the State Information page allowing you

to start a new state return. Click the link <Start a New State Return>. After all states are completed, <Save

& Continue Return>.

15
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REVISIT: To edit or make changes on the state return

NOTE: Any changes made to the Federal inputs after a state has been completed will require the state to be
edited.
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Reviewing Forms for a Federal and/or State Return

After reviewing the Tax Summary Tab for Federal and State, click to <Save & Continue Return>. The

software will display all PDF Forms for the return to review and/or print.

NOTE: Pop-up blocker must be disabled and Adobe Reader installed to view forms.
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Completing a Return

By saving from the State Return Tab, the final page of the return inputs is to mark the return as Complete.

Indicate that ‘Yes’ the return is Complete. Then indicate how you are filing the return (Paper File or

Electronically), and that you have reviewed the forms.

Click <Save & Continue Return>.
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Starting a Return – Direct Mode

Adding Personal Information

Once the return has been selected, you will be prompted to enter all Personal Information.

Adding Additional Forms
To add any additional forms, use the Forms Tree from the left column and select the form you would
like to add. You can also add forms from the links within the 1040 Screens.
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Work Pad

TheWork Pad allows for itemization of a specific field that is auto-calculated by the software. The Work Pad
will display with the Federal Forms when ready to print.

NOTE: Double-click on the Work Pad icon to open the Work Pad Screen.
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Work pad override summary tab
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Override Feature

The Override Feature allows for overriding of a calculated field. To enable this feature, click on the Override
button and enter the value
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Starting a State Return – Direct Mode

To start a New State Return, select the State Tab to the left.

Then click on the State you wish to complete

Click Revisit to Edit or make changes

All State Returns have the same layout and are linked from the Forms Tree or within the return.
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Allocating Between Multiple States

To allocate information between multiple states, click the at < Allocate your Federal Income & Adjustments to MI

State >> at the top of the State Tab.
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Running a Return Diagnostic and Completing a Return

Verify: Running a return Diagnostics for Federal and State Returns

Click here to fix. It’s a link where lead you to the form to double check or fix the data entry.

Once you have completed the return, click the <COMPLETE> button at the top of any page to start the Diagnostic Process

The final page of the return inputs is to mark the return as Complete.

Once the diagnostic has completed, you will have the option to <COMPLETE> the return. Click <Save & Close>
or < Save & Redirect to Manage returns>
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During the tax return inputs, the final page of the interview allows you to make this selection

Note: You cannot efile without doing this.

Proceed to Manage Return page and Click Start Payment to create an invoice
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Understanding the Direct Input Layout

When using the Direct Input option, you will notice that any forms generated will be located in the lower right

corner, all Instructions for the specific return will show in the right-hand column and a Refund Meter in the

lower left corner. The Forms Tree has all available forms to the left.

Form Search: To search a certain forms and schedules
ALL Forms: Forms available in the software
Filed Forms: Form added and to be transmitted to the IRS

Review
Forms
In PDF

Auto generated tax refund and owed amount.
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Additional Features – Direct Input

Verify: Running a Diagnostic

Complete: To mark the return completed and Reviewed

Override: See any line of overridden calculation from Federal and State forms.

Work Pad: Form entry where the work pad created

View/Print: To view and print tax forms ( Customer’s copy, preparer’s copy and filing’s copy)

Note: Set the preparer’s note as reminder

Assets: Depreciation details for the current and future years

DM Docs: Document Manager where you can save docs received from your clients.

YOY: Year On Year Comparison

MFJ/MFS: Comparison of taxes between Married filing joint and married filing separately status.

Attachment:Where you can attach PDF files to be efiled in Federal and State returns.

Signature: A build-in signature pad in the software where your client can use you a Mouse, Stylus or an

external signature pad like Topaz siglite. See Sign Pad supported devices in the SetUp < Sign pad>
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Understanding the Client Manager

The Client Manager will be used to:

 Access any existing client return
 Edit and complete an existing client return
 Viewing client forms
Marking a return as paid
 Amending a return already filed through the software
 File Prior Year return

From the <Clients> Tab, select <Manage Return>.

Search for a client by using the <Search> Box, or select to <Show All> client returns.

Once the client return information is searched, to access the Client Manager, double click the return to manage



30

Client Manager Tabs:

Personal Details
Primary Taxpayer
Name SSN
Date of Birth

Return Details
Edit/Complete Return

File Amended Return

Delete Return

File another State

View/Print Forms

File prior year return
Edit Federal to the state

information Bank Product Status

Payment Details
Select how the taxpayer will pay for your service

History Details
Displays history of payment and e-file for the return

Preparer Notes
Edit, review, make notes on the tax return

Return Status
Display of the current status of the tax return

Schedule Appointment

View/Print Letters for this tax return

MyTaxOffice
 An Online Portal for Taxpayer
 The taxpayer can view/print tax forms Remotely sign tax forms.
 Upload tax-related documents such as W2s, driver's license, social security cards, and much more
 Send messages to the preparer and the preparer can respond, in real-time!
 Works on any Web and Mobile browsers in any devices.
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Editing an Existing Return

To edit an existing return that is already within your database, click on the <Client Manager> Tab, select

<Manage Return> then once you have searched for this client, select <Manage> to the right of the

client information.

Navigate to the <Return Details> Tab.

Click <Edit/Complete Return>.

Deleting a Tax Return

To Delete a Tax Return, from the Client Manager > Return Details Tab, click on the option to <Delete Return>.

NOTE: In order to have the ability to delete a tax return, the return must be marked <Incomplete>, not be

marked as paid, and not transmitted at ANY time.

Amending an Accepted Return
Amending a previously Accepted Return filed through the software can be done by going to the Client

Manager Tab > Manage Return. After searching for the client, choose Manage on the right of the client

data.

Navigate to the Return Details Tab and select your link to <File Amended Return>.
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Viewing and Printing a Tax Return

To view or print forms for a client already in your database, go to your Client Manager Tab > Manage Return;

once you have pulled up the client details, double click.

Navigate to the <Return Details Tab> and click to <View/Print Forms>.

Displayed will be all forms and schedules related to the tax return to view and/or print.

Print All Option – Will print all forms, schedules, worksheets, letters, and bank documents for the Client,

Preparer, and Filing copy.

OR Check the needed boxes to print multiple forms and click <Print Selected Forms>.

Email

Customer Copy: To send customer’s copy to email with password protect.

The form will display in PDF Format for viewing, printing or saving.

NOTE: Pop-Up’s MUST be enabled to view forms.
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Chapter Three: E-File Management

E-File Preparation

To e-file a tax return, the return must be <Marked Complete> and selected for <Electronic File>

Making a Payment for a Return

After completing a return and before electronically filing the return, you must indicate how the taxpayer will
pay for the return by clicking the link <Start Payment/Edit Payment/Make Payment>

If necessary, enter the < Manual Rate> or verify the calculated charges. You can <Modify> Federal or State
Charges. When finished, click < ADD New Invoice>
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Modify Charges: Option where you can give discounts or to add charges
Non- banking: Clients pay cash/credit card or checks
Banking: Clients pay you from their refund using the Bank Product partners
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Select which Payment Type and whether to Make Payment Now or Invoice Only

Then select Yes to E-File this return now.

Note: Mark the invoice as completed in order to efile the tax return

Selecting Transmission Type

Next, select how to transmit the returns.

Taxprolink offers the option to file in the following methods: Federal with State; Federal-Only; or State-Only. After
selecting the type of transmission, click the button <Transmit Now>

NOTE: Selecting the option < Add to QUEUE> will move the specific return to the location E-File > Ready to Transmit.
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Getting E-File Acknowledgements

E-File Acknowledgement from Client Manage

To get E-File Acknowledgements, there are two options available. The first is from within the < Client
Manager> Click the link to <Return Status > to see the latest status of the tax return.

The window that opens will have the latest Return Status.



37

CLICK HERE TO EDIT STATE INFORMATION IN FEDERAL

Click the below link to change your state information given in federal. This includes state withheld in W-2,
W-2G, 1099R, CSA-1099-R/CSF-1099-R, Unemployment compensation, 1099INT, 1099DIV, 1099OID, 1099B,
1099MISC, 1099NEC and 1099K.

Get E-File Status from E-File Tab

Click < EFILE>

Queued for Transmit – A tax return that has been set to queue and can transmit for batches
Queued Return – A tax return that has been sent to Taxprolink but not yet sent to the IRS.
Accepted Return – A tax return that has been Accepted by the IRS.
Rejected Return – A tax return that has been rejected by the IRS.
Transmitted Return – A tax return that has been sent to the IRS and is awaiting an

acknowledgement Unfiled Return – A tax return that hasn’t finished or not filed to the IRS

Extension Tab:
Extension returns

Bank Tab:
Bank Product returns
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Rejected Returns

To view Rejected Returns, navigate to E-File

click the button <View Status> to view the rejection message

A window will show with the details of the Rejection from the IRS and State.

After viewing the Rejection, click <Continue Return>

Click State tab to view the rejection message from the state
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Checking the rejection per return from the Manage return <Click Clients> Manage Returns, double click
Clients Name to manage.

1

2

Edit 1. Click Edit if both Federal and states are rejected to view the rejection message.

Rejection: Interview Mode
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Rejection: Direct Mode

Click Continue Return to fix it.

Edit 2. Federal was accepted and State was rejected:

Click edit if state rejected only to view the state rejection

On Interview Rejection returns

2

1

Error Info: to view the rejection message

Edit return: Click <Edit return> Click <Preferences> to view the rejection message and fix.
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Resubmitting a Rejected Return – Client Manager

After the Rejected Return has been corrected, the return can be resubmitted from the Client Manager and
clicking on the Rejected Return. Then click ‘Transmit Now’
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Mark the return before retransmit.

During the tax return inputs, the final page of the interview allows you to make this selection

Direct Input:

Click <Complete> to mark the return Completed and Reviewed

Interview Mode:

Click < Review> Save and continue to < TAXPROLINK, INC - COMPLETE RETURN>
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Removing a Return from Queue status

To remove a return from Queue, click <Efile> Click <Queued>

No Need to check the boxes

for Federal and States

Click < Save and Continue>

You will now have the option to Remove From Queue for Editing or Retransmission at a later date.

Leave the transmissions UNCHECKED to indicate the removal of these returns and click <Save and Continue>
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Chapter Four: Using the Taxprolink Features

Scheduler

The Scheduler is a feature that allows you to manage your existing or prospective customer’s appointment
schedule. Daily reports are available as well as customizable work hours and meeting durations

Letters

Creating Custom Letters To create a Custom Letter, go to the Setup Tab > Settings > Create Custom Letter.

To create a Custom Letter, name the letter and enter the information to generate the letter. There are Custom
Fields that can be auto-inserted into the letter by clicking the preferred field and clicking the button >>. Once the
letter is complete, click <Save Letter>
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Client Organizer

To access the Client Organizer, click <Letters > Client Organizer.



46

Tools

The Estimator will generate a basic estimation of the anticipated Refund or Amount Due. Enter as much

information as the taxpayer gives, then click the button <Calculate> . The Quick Estimator can be Printed using

the <Print>link

Click<Start New Return>
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MFJ vs. MFS Comparison Chart

The MFJ vs. MFS Comparison Chart can be accessed by going to Tools > MFJ vs. MFS Comparison Chart.

Depreciation:

To create Depreciation schedule

Depreciation Summary: listing of returns on 4562 entries (Depreciation details)
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Reports:

Standard Report: Client Returns

Next, click on the drop down menu for the Category of Report you wish to generate. Then specify how to sort the

Report by selecting from the Based On drop down menu. Once the report has been selected, click the button

<Click View & Print Report> . After the report has been generated, the options of Printing, Exporting to Excel, or

Previewing are available.

E-File Data Report
To access the E-File Data Report, navigate to Reports > E-File

Office Revenue Report
To access the Office Revenue Report, navigate to Reports > Office Revenue Report.

Custom Report
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Text Messaging

Now Taxprolink has feature to send and receive messages from your tax office individual clients.

To activate your sub-preparer's text messages feature to their account:

Click <SETUP> <SETTINGS> PREPARER/CLIENT LEVEL

Choose one of your tax preparer's Account Name and Check Allow Text Messages to allow your employees use
the text messages feature to communicate with clients.
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Chapter Five: Fee- Collect Options

Processing a Bank Product Return

For Fee-Collect options, Taxprolink offers many partners. In order to access this payment option from within the
tax return, you must have the return Marked Complete and selected for Electronic Filing. Then click < Start
Payment / Edit Payment / Make Payment>

Choose < BANKING> Click <Continue>

NOTE: You must REGISTER AND BE APPROVED by an Taxprolink Bank Partner before this option will be available.
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After clicking on the tab of your Bank Partner, you will have the option to select any and all products offered by
that Bank Partner. Complete the required information.

PreAck: Advance loan program offers from January 2 to the day of the IRS starts accepting returns.

Disbursement:
Checks: Bank will send a black check to print the taxpayer’s advance loans and refund transfer in your office.
Cards: Bank send cards for taxpayer’s doesn’t have a banking information
Direct Deposit: Banking information must be entered in the tax return before choosing this option.

SRT (State Refund Transfer) – A state refund transfer. If federal doesn’t payment your fees. The amount will be
taken from the state refund.

The screens that follow will guide you through generating the necessary documents and provide all disclosure
documents before allowing e-filing of the tax return.

Bank Product Partners
Bank Products allow the taxpayer to pay the ERO fee’s out of the refund and receive the refund disbursement after all fees have

been deducted. All Taxprolink Bank Product Partners can be found at https://www.taxprolink.com/bank-products.html



Chapter Six: Business Returns

Clients:

Business Forms Available:

1120s: U.S. Income Tax Return for an S Corporation
1120: U.S. Corporation Income Tax Return
1065: U.S. Return of Partnership Income
1041: U.S. Income Tax Return for Estates and Trusts
990: Return of Organization Exempt from Income Tax
720: Quarterly Federal Excise Tax Return
706: United States Estate (and Generation-Skipping Transfer)
290: Heavy Highway Vehicle Use Tax Return
709: United States Gift (and Generation-Skipping Transfer)
710: 5500: Annual Return/Report of Employee Benefit Plan

8849: Claim for Refund of Excise Taxes
52
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Creating a Business Return

Click <Clients> Choose <Business Forms> Click <Create New Return>
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Form Search: To look a form name or form number.

All Forms:
Business Forms Available

Filed Forms:
Forms added and to be efiled to the IRS

Complete tab:
Once you have completed the return, click the <Complete> button at the top of any page to start the
Diagnostic Process.

Override:
The Override summary to see which forms and line calculations have been overridden.

Work Pad:
TheWork Pad summary where you can see the tax forms and schedules have been overridden.

DM Docs:
Document Manager where you can save documents received from the taxpayer.

Attachment:
Pdf attachment to be sent to the IRS.

YOY
Year On Year Comparison



Completing a business return:

Running a Return Diagnostic and Completing a Return

Once you have completed the return, click the <Complete> button at the top of any page to start the Diagnostic
Process

Click <Federal> and <State> to see the errors in the return.

If there are any issues with the return, a display box will show with any errors that must be corrected before the

return can be <Marked Complete> You should either <Click here to fix> (if available) or <Close & Correct

errors>

55
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To bypass the error if not applicable in the tax return

Click <Ignore & Continue>

NOTE: You have the option however it is NOT RECOMMENDED

Once the diagnostic has completed, you will have the option to <Complete and Review> the return. Click
<Save & Close> or <Save & Redirect to Manage Return>
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Making a Payment for a Return

Manage Return – Payment Details

Click < Client Payment> Click <Add New Invoice>

Invoice created:
Edit / Modify Charges: To change the pricing amount
Make Payment: To mark the invoice completed and efile
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Efile Transmission:

Check the box to Federal E-File or check to file the State-Only E-File

If filing Federal and State together, verify the state that will Piggyback (E-file with) Federal.

Click <Transmit Now> and this tax return will be Queued for Transmission to the IRS.

Note: Once the invoice is complete the Ready to E-file is available to click
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Efile Tab:

To check the status of business tax returns

Choose business return in the dropdown menu
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Tools:

To import prior year business returns to the current tax year.

Choose the business form from the dropdown menu and click <Import Data>

Note: Once you import from 2019 to 2020, the import data is no longer available in the 2019 import tool. In
order to reimport, please delete the return from 2020 database. Once you delete it in 2020, it should be
available for import tool 2019TY.

To delete a tax return. Click <Mark the return Incomplete> Click <Delete tab>
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Updating Pricing Information

The Pricing Information can be updated here. This will be the fee’s that you charge to your taxpayers and
while it is not required that you setup this information now, it is recommended.

Choose your pricing option for every return:
Fixed rate for all returns
Set Price as Per Form
Set price manually after every return
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Chapter Seven: Glossary

Accepted Return – A tax return that has been Accepted by the IRS.

Forms Tree – The forms tree is the list of all available forms within the Direct Input preparation screen.

Queued Return – A tax return that has been sent to Taxprolink but not yet sent to the IRS.

Piggyback State – A state return that will transmit along with the Federal Return.

Rejected Return – A tax return that has been rejected by the IRS.

Transmitted Return – A tax return that has been sent to the IRS and is awaiting an acknowledgement

Disabled Account – Account is disabled due to accessing from outside USA. Tax preparers may use a VPN

and set to US server to access the software.

EIN DB – EIN auto-save on the database, will auto populate the employer’s information when key in the ein

in the tax return.

IP Security - Restricting staff’s logins in a specific location.



Taxprolink Support Timing Schedules Jan 2 – May 31

Monday –Friday 9 am - 11 pm EST
Saturday 10 am - 6 pm EST
Sunday 12pm – 6pm EST

June 1 – December 31
Monday – Friday 9am -9pm EST
Saturday 10 am - 6 pm EST
Sunday - Closed

Support: (800) 746-8901
Text Line: 248-864-2275 / 248-716-7999
25200 Five Mile Road
Redford Charter Township MI 48239
support@taxprolink.com
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